インタフェースの学習
マニュアル     リファレンス     スクリプト   
Unityマニュアル > ユーザガイド > Unityの基礎 > インタフェースの学習

このドキュメントは有志により翻訳されたもので、オフィシャルではありません。オリジナルのページはこちら
This document is unofficially translated by users.Please see the original document here.

翻訳に関する修正など、ご連絡はこちらまで。
Please send e-mail to here, when you have any question about the translation.

インタフェースの学習

初めての起動

さあ、Unityの学習を始めましょう。もしUnityをまだ起動していなければ Applications->Unity [Mac]Start->Programs->Unity [Win]から起動してください。初めて起動するとUnity Editorが表示されます。


デフォルトではTropical Paradiseプロジェクトの"Islands"シーンが表示されています。

Unityエディタインタフェースを眺めてみましょう。Main Editor Windowには、いくつかの ビューと呼ばれる タブが有ります。Unityには用途に合わせて様々なビューが準備されています。

では、それぞれのビューについて見てみましょう。

プロジェクトビュー(Project View)

全てのUnityプロジェクトはAssetsフォルダを含みます。このフォルダに含まれているものがProjectビューに表示されます。ゲームで使用する全てのAssetをここに配置します。シーン(scene)やスクリプト(scripts)3Dモデル(3D models)テクスチャ(texture)オーディオ(audio files)プレハブ(prefabs)等です。ProjectビューにあるAssetの上で右クリックし、 Reveal in Finder [Mac] (Reveal in Explorer [Windows])を選択するとファイルシステム上の実際のファイルを見る事が出来ます。

重要: Project AssetをOS上で動かすとメタデータを破損する可能性があります。必ずプロジェクトビューを使ってAssetを管理してください。

ファイルをプロジェクトビューにドラッグすればAssetをプロジェクトに追加できます。または、Assets->Import New Assetメニューから行えます。Assetをゲーム内で使う準備ができました。Assetについて詳しく知りたければ、マニュアルのAsset Workflowの章を読んでください。

シーンもProjectビューに配置されます。これらは独立した階層だと考えてください。例えば、はじめにUnityを起動すると、Islandsシーンがデフォルトでロードされます。Command-N[Mac] (Control-N[Win])で新しいシーンを作成します。現在のシーンをProjectビュー内で保存するにはCommand-S[Mac](Control-S[Win])を使用します。

いくつかのゲームAssetはUnityの中で作成します。Createドロップダウンか、右クリックからCreateを選択してください。


Create ドロップダウン

スクリプトやプレハブ、フォルダをプロジェクト内で管理するのに私用します。Assetやフォルダの名前を変更するにはEnter[Mac](F2[Win])、または間隔をあけてAssetの名前を2度クリックします。Altキーを押しながらクリックすると、サブフォルダも含めて開いたり閉じたりできます。

階層(Hierarchy)


階層はシーン中のすべてのゲームオブジェクトを含みます。ゲームを構成する、3Dモデルのようなファイルから直接使われるインスタンスやプレハブのようなカスタムオブジェクトです。親オブジェクトを階層から選択できます。シーンにオブジェクトが追加されたり削除されたりすると、階層にも追加(削除)が行われます。

親子関係の設定(Parenting)

Unityでは親子関係が設定できます。ゲームオブジェクトを他のオブジェクトの子供とするには、階層において、子オブジェクトを親にしたいオブジェクトの上にドラッグします。子供は親の移動や回転を受け継ぎます。親オブジェクトを開く(閉じる)ことで、ゲームに影響を与えずに親子関係を確認できます。


2つの親子関係がないオブジェクト

親子関係が設定された

親子関係の設定についてはTransform Component ページの親子関係の章を参照してください。.

ツールバー(Toolbar)

ツールバーは5つのコントロールからなります。それぞれエディタの異なる部分に関連します。

Transform Tools -- シーンビュー移動ギズモとともに用いられます
Transform Gizmo Toggles -- シーンビュー表示を変更します
Play/Pause/Step Buttons -- ゲームビューで使用します
Layers Drop-down -- シーンビューに表示するオブジェクトを制御します
Layout Drop-down -- ビューの配置をコントロールします

シーンビュー(Scene View)


シーンビュー

シーンビューはインタラクティブなサンドボックスです。シーンビューを使い環境やプレイヤー、カメラ、敵、その他のゲームオブジェクトを選択し移動します。シーンビューでオブジェクトを扱うことはUnityの重要な機能ですので、効果的に作業できるようになることが重要です。

  • マウスの右ボタンを押したままにしフライスルーモードが開始します。マウスとWASDキーを用いて一人称視点ナビゲーションが行えます。
  • ゲームオブジェクトを選択しFキーを押すと、選択したオブジェクトのピボットがビューの中心に表示されます。
  • Altキーを押したままドラッグすると現在のピボットを中心にカメラが回転します。もし、3ボタンマウスを使っていれば
    • Altキーを押したまま中ボタンをドラッグすることでシーンビューカメラを移動できます。
    • Altキーを押したまま右ボタンをドラッグするとズームします。マウスのホイールをスクロールしてもズームできます。
もし1ボタンマウスを使っている場合は手ツール(Hand Tool)(ショートカットキー Q)を使うとよいでしょう。
Altキーを押しながらドラッグすると回転します。
Command[Mac](Control[Win])キーを押しながらドラッグするとズームします。

ゲームオブジェクトの配置

ゲームを作成する場合、多くの異なるオブジェクトをゲーム中に配置します。ツールバーの中の移動ツールを用いて移動、回転、サイズ変更がそれぞれのゲームオブジェクトに対して行えます。シーンビューでゲームオブジェクトを選択すると対応するギズモが表示されます。マウスを使ってギズモの軸を使ってゲームオブジェクトを移動(Transform)させたり、直接数値をインスペクタの中にある数値フィールドに入力して移動したりできます。


  • ギズモの軸をドラッグしているときにCommand[Mac](Control[Win])キーを押すことで、スナップ設定(Snap Setting)で設定した値を用いて、一定間隔で値を変化させられます。
    • スナップ設定はEdit->Snap Settings...から変更できます。
  • ギズモの中心をドラッグするとオブジェクトをすべての軸に沿って動かせます。
    • Command[Mac](Control[Win])キーを押しながら中心をドラッグすることで、オブジェクトが衝突物(Collider)にスナップします。オブジェクトを正確な位置に移動する場合に便利です。
  • 3ボタンマウスを使っている場合中ボタンをクリックすると、軸を最後に調整した軸(黄色に変わります)に合わせられます。
  • 拡大ツールを使う場合、一定でない拡大(e.g. 1,2,1)を行うと、子オブジェクトに予期しない拡大が起こる場合がありますので注意してください。
  • ゲームオブジェクトの移動に関してはTransform Componentのページを参照してください。

ギズモディスプレイトグル(Gizmo Display Toggles)はギズモの位置定義に使用されます。


ギズモディスプレイトグル
  • 位置(Position):
    • Center はオブジェクトの描画範囲中心にギズモ中心を位置します。
    • Pivot はメッシュの実際のピボット位置にギズモが位置します。
  • 回転(Rotation):
    • Localはオブジェクトの回転に相対的な位置を保持します。
    • Globalグローバルはギズモをワールドスペースの向きに合わせます。

シーンギズモ(Scene Gizmo)

シーンビューの右上にシーンギズモがあります。シーンカメラの向きを表示し、ビューの向きを変更することができます。ギズモの腕をクリックすることでシーンカメラを特定の向きにスナップしたり平行投影モード(Isometric Mode)に変更したりできます。平行投影モードでは、右ボタンドラッグで回転、Altキーを押しながらドラッグすることでパンします。シーンギズモを中ボタンクリックすることでモードから抜けられます。中ボタンをShiftクリックすると平行投影モードを開始します。


透視投影モード(Perspective mode)

平行投影モード 距離に応じてオブジェクトが小さく表示されません!

シーンビューコントロールバー(Scene View Control Bar)


初めのドロップダウンで描画モード(Draw Mode)を選択します。テクスチャ描画、ワイヤフレーム、テクスチャとワイヤフレームのモードが選べます。これはゲーム公開時には影響しません。


描画モードドロップダウン

次のドロップダウンはレンダリングモード(Rendering Mode)を選択します。RGBアルファ(Alpha)上書き(Overdraw)ミップマップ(Mipmaps)が選べます。これもゲーム公開時には影響しません。


レンダリングモードドロップダウン
  • RGBはすべての色を通常通り描画します。
  • アルファは透明度の調整や最大画面効果に用いるアルファ値のみを描画します。
  • 上書きはどの程度のスクリーンが上書き時間を消費するかを示します。
  • ミップマップはテクスチャのサイズを示します。 -- 赤はテクスチャが大きすぎる、青はテクスチャが大きくなる可能性があることを意味します。テクスチャのサイズはゲーム実行時の解像度に依存します。

次は、シーンライティング(Scene Lighting)ゲームオーバレイ(Game Overlay)ボタンです。

シーンライティングを有効にすると、デフォルトのシーンビューライティングを、あなたが設定したライティングで上書きします。ゲームオーバレイはシーンビュー内でSkyboxGUI要素(GUI Elements)を有効化します。

ゲームビュー(Game View)


The ゲームビューはゲーム中のカメラによりレンダリングされます。ゲーム公開時のビューとなります。プレイヤーがゲームをプレイする場合は複数のカメラをコントロールする必要があるでしょう。カメラに関する情報はCamera Componentのページを参照してください。

プレイモード(Play Mode)

ツールバー内のブタンを用いてエディタのプレイモードを操作し、公開時のゲームプレイをテストします。プレイモードで行った変更は一時的なもので、プレイを終了するとすべてリセットされます。プレイ中は変更が一時的であることを示すため、エディタUIは暗く表示されます。

ゲームビューコントロールバー(Game View Control Bar)

ゲームビューコントロールバーの最初のドロップダウンはアスペクトドロップダウン(Aspect Drop-down)です。ゲームビューウィンドウのアスペクト比を強制的に変更できます。異なるアスペクト比を持ったディスプレイでの表示をテストすることが可能です。

右のほうに プレイ時に最大化(Maximize on Play)トグルがあります。有効化すると、ゲームビューはゲームプレイ時にエディタウィンドウがフルスクリーンで表示されます。

さらに右にギズモ(Gizmos)トグルがあります。有効化するとすべてのギズモがシーンビューに表示され、また、ゲームビューにも表示されます。これはギズモクラス関数を使うすべてのギズモを含みます。

最後にStatsボタンがあります。これは レンダリングのステータス(Rendering Statistics) ウィンドウを表示します。描画パフォーマンスの調整(Optimizing Graphics Performance).に有効です。

インスペクタ(Inspector)


Unityのゲームはメッシュ、スクリプト、サウンドや ライト(Lights)等、グラフィカルな要素を含むゲームオブジェクトからなります。インスペクタは選択しているゲームオブジェクトの詳細を付属コンポーネントや属性も含めて表示します。ここで、ゲームオブジェクトのシーン中での機能を編集します。 ゲームオブジェクトとコンポーネントの関係について理解することは重要です。

インスペクタに表示されるプロパティは直接編集できます。スクリプトの変巣であってもスクリプト自体を変こすることなく編集できます。インスペクタを使い実行時の環境変数を変更し、ゲームのマジックゲームプレイを発見できます。スクリプトでオブジェクト型(GameObjectやTransform)のpublic変数を定義すると、ドラッグアンドドロップによってゲームオブジェクトやプレハブをインスペクタ上で割り当てることができます。

インスペクタにおいてコンポーネント傍のはてなマークをクリックすると、コンポーネントのリファレンスページが開きます。Unityのコンポーネントに関する詳細なガイドは Component Referenceを参照してください。


コンポーネント(Component)メニューからコンポーネントを追加

小さなギアアイコンをクリック(または、コンポーネント名を右クリック)すると、対応するコンテクストメニューが開きます。

インスペクタは選択されたAssetファイルのインポート設定も表示します。


ApplyをクリックしAssetを再インポートします。

レイヤ(Layer)ドロップダウンを使いレンダリングレイヤをゲームオブジェクトに設定します。タグ(Tag)ドロップダウンを使いタグをゲームオブジェクトに割り当ててください。

プレハブ(Prefabs)

プレハブを選択すると、いくつかのボタンがインスペクタに表示されます。プレハブに関しては、プレハブマニュアルページを参考にしてください。

アニメーションビュー(Animation View)

Unity2.6の新しいアニメーションビューは、強力なアニメーション編集ツールです。アニメーションビューの使い方はアニメーションビューガイドを参照してください。

ステータスバー(Status Bar)

エディタ下部にあるステータスバーは様々な用途に利用されます。コンパイルエラーやデバッグログの表示を行います。ゲームに何か問題が発生した場合は、ステータスバーを見ることがエラー発見に役立ちます。ステータスバーをダブルクリックすることでコンソールウィンドウが開き、スクリプトの実行時エラーを確認できます。

コンソール(Console)

ステータスバーに表示されたエラーをダブルクリックするか、 Window->Consoleから コンソールを開きます。

コンソールはゲームのメッセージ、警告、エラーやデバッグ出力を表示します。独自のメッセージをコンソールに送るには Debug.Log()Debug.Error()を用います。メッセージをダブルクリックすることで、スクリプトの該当部分にジャンプします。また、コンソールツールバーにはいくつかのオプションがあります。

コンソールツールバーのオプションはわかりやすいものがほとんどですが、ひとつだけ説明が必要です。エラーポーズ(Error Pause)が有効な場合、Debug.Error()を呼び出すと、ゲームが一時停止しますが、Debug.Log()の呼び出しでは停止しません。

ワークスペースのカスタマイズ

ビューのレイアウトはタブをドラッグすることによって変更できます。タブをすでに開いているウィンドウの タブエリアにドロップすれば、その隣にタブが配置されます。タブを ドックゾーンにドロップすると、新しいウィンドウにビューが配置されます。


ビューは開いているウィンドウの横や下部にドッキングできます。

タブはマインエディタウィンドウから取り外し、フローティングエディタウィンドウとして利用することもできます。フローティングウィンドウには、ビューやタブをメインウィンドウと同様に配置できます。


フローティングエディタウィンドウはメインエディタウィンドウと同じですが、ツールバーがありません。

エディタウィンドウのレイアウトを作成したら、それを保存できます。レイアウトドロップダウン(ツールバーにあります)を開き Save Layout...を選びます。新しいレイアウトに名前をつけ保存すれば、以降はレイアウトドロップダウンから選択できるようになります。


完了したカスタムレイアウト

タブを右クリックすることでビューの最大化や新しいタブの追加などの追加オプションを選択できます。

このドキュメントは有志により翻訳されたもので、オフィシャルではありません。オリジナルのページはこちら
This document is unofficially translated by users.Please see the original document here.

翻訳に関する修正など、ご連絡はこちらまで。
Please send e-mail to here, when you have any question about the translation.